Petition: Rename TDD

A little tongue in cheek, but I think that TDD (test driven design) should be renamed to DbT (Design[ed] by Test[ing]).

1) Design is the most important part of the TDD mantra so put it first.
2) DbT can be pronounced "debit" which is defined as "an accounting entry that results in either an increase in assets or a decrease in liabilities or net worth". Either way, the bean counters can appreciate the connotation.
3) Should help get over the hump of BDD adoption being "easier" than TDD.


One thought on “Petition: Rename TDD

  1. I hear you brother. I’d sign that… oh wow, would I sign that.

Leave a Reply

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s